This project has moved. For the latest updates, please go here.

Copy UNC Path

Aug 10, 2012 at 5:13 AM
Edited Aug 10, 2012 at 10:35 AM

Hi,

When navigating to C:\SomeDir\SomeFile.file I cannot use any of the UNC copy profiles. Even with the hidden shares setting enabled, they are greyed out. Any other $ share works fine.

It would be good if using any of the UNC copy profiles on the C$ share would either provide \\CompName\C$\SomeDir\SomeFile.file or perform the same behavior as it did in earlier versions where it copied just the long full path.

Not sure if part one is by design, and not sure if anyone wants part two; never hurts to ask :)

Cheers

Coordinator
Aug 12, 2012 at 9:34 PM

Indeed, I get the same behavior here - for some reason, UNC commands are not enabled for all drives, which is illogical. I'll convert this to a work item and look into it immediately. Thanks for the report!

Coordinator
Aug 12, 2012 at 9:35 PM
This discussion has been copied to a work item. Click here to go to the work item and continue the discussion.
Coordinator
Aug 16, 2012 at 10:05 PM

Hello,

 

I just tried it here and indeed, it looks like the UNC commands are not properly being enabled in some circumstances. I see you've started a discussion on the Path Copy Copy website too, so I'll turn it into a work item, as it definitely looks like a bug. Thanks for the report. You can follow up on the eventual bug fixing by checking out the work item and subscribing to it if you want.

 

- Charles

 


On August 10, 2012 at 1:13 AM Smi9A6 <notifications@codeplex.com> wrote:

From: Smi9A6

Hi,

Have been using Path Copy Copy for some time and have noticed that since upgrading I have lost the Copy UNC Path option and gained a potential of four others.
On top of this, none of them work when navigating to C:\SomeDir\SomeFile.file

It used to turn that into the UNC path of: \\CompName\C$\SomeDir\SomeFile.file whereas now they are all greyed out. And yes I have enabled hidden shares.

This was actually an issue on 10.1 as well ...

Any help would be appreciated!


 
Coordinator
Aug 16, 2012 at 10:06 PM

Hello,

 

After some testing on my end, I have a similar behavior with the latest version, but I know why - what I am unsure, however, is why *you* have this behavior... Would you like to help me diagnose this a bit more? If so, could you please export the following registry key and send me the result:

 

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer\Shares

 

To export the registry key, perform the following operations:

1. From the Start menu, choose "Run..."

2. Type "regedit" and press OK

3. In the Registry Editor's tree view (left pane), navigate to the above key

4. From the File menu, chose "Export..."

5. Enter a name for the registry export file

6. In the "Export range" group box, make sure "Selected branch" is selected

 

This will result in a .reg file. Since those files are often considered unsafe by mailers, please rename it to change its extension to ".ini". Then send me the file.

 

Thanks in advance!

 

- Charles Lechasseur


On August 10, 2012 at 1:13 AM Smi9A6 <notifications@codeplex.com> wrote:

From: Smi9A6

Hi,

Have been using Path Copy Copy for some time and have noticed that since upgrading I have lost the Copy UNC Path option and gained a potential of four others.
On top of this, none of them work when navigating to C:\SomeDir\SomeFile.file

It used to turn that into the UNC path of: \\CompName\C$\SomeDir\SomeFile.file whereas now they are all greyed out. And yes I have enabled hidden shares.

This was actually an issue on 10.1 as well ...

Any help would be appreciated!


 
Aug 17, 2012 at 2:23 AM

Hi Charles;

Sorry for the late reply. I am at work, and work is damn busy.

Please find attached the Lanman Server Share key in ini file format. I noticed that neither D$ nor C$ show up, yet both are accessible from other computers.

Adam Smith-Platts

Desktop SOE Engineer | IM&T Applications – Software Delivery
+61 2 6214 2946
| Adam.Smith-Platts@csiro.au | www.csiro.au

1 Wilf Crane Crescent, Yarralumla ACT 2600

Please consider the environment before printing this email.

From: clechasseur [email removed]
Sent: Friday, 17 August 2012 9:15 AM
To: Smith-Platts, Adam (CSIRO IM&T, Yarralumla)
Subject: Re: Copy UNC Path [pathcopycopy:390958]

From: clechasseur

Hello,

After some testing on my end, I have a similar behavior with the latest version, but I know why - what I am unsure, however, is why *you* have this behavior... Would you like to help me diagnose this a bit more? If so, could you please export the following registry key and send me the result:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer\Shares

To export the registry key, perform the following operations:

1. From the Start menu, choose "Run..."

2. Type "regedit" and press OK

3. In the Registry Editor's tree view (left pane), navigate to the above key

4. From the File menu, chose "Export..."

5. Enter a name for the registry export file

6. In the "Export range" group box, make sure "Selected branch" is selected

This will result in a .reg file. Since those files are often considered unsafe by mailers, please rename it to change its extension to ".ini". Then send me the file.

Thanks in advance!

- Charles Lechasseur


On August 10, 2012 at 1:13 AM Smi9A6 <notifications@codeplex.com> wrote:

From: Smi9A6

Hi,

Have been using Path Copy Copy for some time and have noticed that since upgrading I have lost the Copy UNC Path option and gained a potential of four others.
On top of this, none of them work when navigating to C:\SomeDir\SomeFile.file

It used to turn that into the UNC path of: \\CompName\C$\SomeDir\SomeFile.file whereas now they are all greyed out. And yes I have enabled hidden shares.

This was actually an issue on 10.1 as well ...

Any help would be appreciated!