This project has moved. For the latest updates, please go here.

Surrounding paths with < and >

Oct 1, 2012 at 9:17 PM

Your program would be much more useful to me if, in lieu of quotes, I could surround a path with < and >. When pasted into an email or doc, the path then immediately becomes a link. Quotes don't do this.

Coordinator
Oct 2, 2012 at 8:15 PM
jimsstone wrote:

Your program would be much more useful to me if, in lieu of quotes, I could surround a path with < and >. When pasted into an email or doc, the path then immediately becomes a link. Quotes don't do this.

That's a nice addition. I'll enter a work item to implement it in a future version.

In the meantime, you can reproduce this functionality with a custom command using regular expressions:

  1. Open the settings via Path Copy -> Settings...
  2. Under the Custom Commands tab, choose "New..."
  3. Under Base Command, choose the kind of path you want to work with
  4. Under Options -> Find / Replace, select "Use regular expressions"
  5. In the "Find what" box, enter: ^(.*)$
  6. In the "Replace with" box, enter: <$1>
  7. Enter a name for your custom command at the top of the window
  8. Click OK to save the new command, then Apply to commit the changes

You can also change the position of this command via the Commands tab and even choose for it to appear in the main menu if needed.

Let me know if the workaround works for you in the meantime.

Coordinator
Oct 2, 2012 at 8:16 PM
This discussion has been copied to a work item. Click here to go to the work item and continue the discussion.
Oct 2, 2012 at 9:03 PM
The workaround works great with one small twist: I had "Add quotes around copied paths" checked under Advanced, but left "Enclose path in quotation marks" unchecked in Custom Command > Options. Quotes got added anyways. So I unchecked "Add quotes around copied paths", and now it's perfect. Thanks.


From: [email removed]
To: [email removed]
Date: Tue, 2 Oct 2012 13:16:31 -0700
Subject: Re: Surrounding paths with < and > [pathcopycopy:397605]

From: clechasseur
This discussion has been copied to a work item. Click here to go to the work item and continue the discussion.
Read the full discussion online.
To add a post to this discussion, reply to this email (pathcopycopy@discussions.codeplex.com)
To start a new discussion for this project, email pathcopycopy@discussions.codeplex.com
You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe on CodePlex.com.
Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at CodePlex.com
Coordinator
Oct 2, 2012 at 9:42 PM
jimsstone wrote:
The workaround works great with one small twist: I had "Add quotes around copied paths" checked under Advanced, but left "Enclose path in quotation marks" unchecked in Custom Command > Options. Quotes got added anyways. So I unchecked "Add quotes around copied paths", and now it's perfect. Thanks.

No problem. The behavior you describe is correct - selecting "Add quotes around copied paths" will add the quotes no matter what. To selectively add them, you need to create custom commands for those you need quotes.